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A.  Introduction 
To work with the agent-based models in Chapters four, five, and six of the report Complexity Science – an 
introduction (and invitation) for actuaries (the “report”), you will need three modeling platforms: 
 R with Eclipse and igraph, to work with the networks in Chapter four. 
 Microsoft Excel with Visual Basic for Applications (VBA), to work with the cellular automata in 

Chapter five. 
 Repast Simphony with Java and Eclipse, to work with the artificial societies in Chapter six. 
 
This document shows you how to set up these platforms and start to work with them. All the platforms are 
easily available. R, igraph, Eclipse, Repast Simphony, and Java are Free Software under the terms of the 
Free Software Foundations’s GNU General Public License; and most actuaries have easy access to Microsoft 
Excel with VBA. 
 
Although these instructions are current as of May 2010, by the time you read them, they may be out of 
date. In particular, a new version of Repast Simphony, with new documentation, is scheduled to be released 
in late 2010. So, please use these instructions with caution. 
 
Even though you may be familiar with Excel, to apply Complexity Science concepts it is critical that you 
also learn R, Eclipse, igraph, Java, and Repast Simphony. Because Excel cannot model networks, to work 
with networks you will need R and igraph. Also, even with fast processors, Excel is too slow to run most 
agent-based models; you will need the more powerful capabilities of Java and Repast Simphony. 

B.  R, Eclipse, and igraph 
 
R 
‘R’ is a high-quality environment for statistical computing and graphics. It provides both traditional and 
cutting-edge functionality, and is often the preferred tool for academic research and business statistical 
applications. It can be used on nearly all operating systems, including Windows, MaxOS X, and Linux. 
 
To install R, go to “www.r-project.org” (‘The R Project for Statistical Computing’). Then choose a CRAN 
(‘Comprehensive R Archive Network’) ‘mirror’ site near you, and download the version of R appropriate 
for your operating system. 
 
If you are new to R, after you download and install it, click on “Help > Manuals (in PDF) > An 
Introduction to R”, and read the manual. It is easy to read, and helpful. 
 
Eclipse 
Elipse is an excellent interactive editor and programming environment, especially designed for Java 
applications. I suggest that you use it with R and igraph. To work with the networks in Chapter four of the 
report, you will use Eclipse to import and manipulate a set of R functions (see below).  
 
To download and install Eclipse, go to “www.eclipse.org/downloads” (‘Eclipse Downloads’). Click on the 
‘Eclipse Classic’ version, then choose a ‘mirror’ site near you and follow the instructions to download and 
install Eclipse.  
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B.  R, ECLIPSE, AND IGRAPH 
 
Eclipse continued 
Eclipse is downloaded as a .zip file. Once the download is complete, extract the Eclipse files to the folder 
from which you want to run Eclipse. For example, on my Windows 7 system, I created a folder named 
‘Eclipse’ under my ‘Program Files (x86)’ folder, and extracted the Eclipse files to this folder. I then 
renamed the extracted ‘eclipse’ folder to the particular version of Eclipse that I downloaded. This way, I 
can download different versions of Eclipse to the same ‘Eclipse’ folder. 
 
The Eclipse installation process is refreshingly simple. It does not entangle itself with your computer (such 
as becoming part of your computer’s registry). It simply sits self-contained on your hard drive, waiting to 
be used. To uninstall Eclipse, all you need to do is go to where it sits and delete it. 
 
To run Eclipse, you also need to have the Java runtime environment. You probably already have this on 
your computer, but if not you can easily download it from “java.com/en/download/index.jsp” and install 
it. 
 
An excellent (but now dated) book to learn about Eclipse is Burd (2005) (see references on the last page). If 
you have previously used programming editors, you should have no trouble with the basic functionality of 
Eclipse. But because Eclipse is extremely powerful and full-functioned, learning more about it may 
substantially increase your programming efficiency. 
 
The R functions to reproduce the sample network models in Chapter four are available as a zipped file on 
the SOA web page for the report. To download the zipped file, click on ‘Network functions’. Then unzip 
the file, and save the unzipped (extracted) contents to a temporary place on your hard drive (such as 
“D:/temp”). Unzipped, the file contains a folder named named ‘NetworkFunctions’ (which is an Eclipse 
‘package’). This folder in turn contains two files, one named ‘.project’ and one named 
‘ComplexityScience_NetworkFunctions_v1a.R’. Use Eclipse’s ‘File > Import > General > Existing 
Projects into Workspace’ function to browse to the folder (‘root directory’) ‘NetworkFunctions’ and 
import the package NetworkFunctions (and its two files) to your Eclipse workspace (be sure to check the 
box labeled ‘Copy projects into workspace’). Once it is imported, you will see a new package called 
‘NetworkFunctions’ in the Eclipse Package Explorer window. Under the folder ‘NetworkFunctions’ you 
will find a file named ‘ComplexityScience_NetworkFunctions_v1a.R’; double click on this file to open and 
use it.  
 
igraph 
‘igraph’ is a large R library of functions for creating, manipulating, analyzing, and visualizing graphs. It 
contains many flexible algorithms, and is powerful enough to handle graphs with millions of vertices and 
edges. To install igraph, in your R environment click on “Packages > Install Package(s)” and select a CRAN 
mirror site near you. Then select igraph from the list of packages. After igraph is successfully downloaded, 
type “library(igraph)” on the R command line to load it for use (or, alternatively, click on “Packages > Load 
package … > igraph”). 
 
After you have installed and loaded igraph, open the R file with network functions 
(“ComplexityScience_NetworkFunctions_v1a.R”), and read its introductory section. The best way to 
learn igraph is to start using the functions in this file. As you use igraph, you will find it helpful to have a 
copy of its documentation on your computer desktop in PDF format:  Csardi (2009).  
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C.  Microsoft Excel and VBA 
If you need to obtain a copy of Microsoft Excel, go to “office.microsoft.com” to download the latest 
version. If you don’t want to purchase the software immediately, you may be able to obtain a free trial 
version. To download and install Excel, follow the Microsoft instructions. 
 
If you have Microsoft Excel, you also have Visual Basic for Applications (VBA); they come bundled. A good 
way to learn about VBA is to read the book by Walkenbach (2007). 
 
Four Excel models, found on the report’s SOA web page, are explored in Chapter five of the report: 
 One-dimensional cellular automata (the file name is “research-complexity-model-1dca-v1a.xlsm”) 
 Two-dimensional cellular automata (the file name is “research-complexity-model-2dca-v1a.xlsm”) 
 Sandpile model (the file name is “research-complexity-model-sandpile-v1a.xlsm”) 
 Forest fire model (the file name is “research-complexity-model-forestfire-v1a.xlsm”) 

D.  Java and Repast Simphony 
 
Java 
Java is an object-oriented programming language that produces software that runs on any operating system. 
In order to use Repast Simphony, you will need to install a developer’s version of Java. To do this, go to 
“java.sun.com/javase/downloads/index.jsp” and download the latest Java Development Kit. 
 
To learn Java, you may enjoy the book by Sierra & Bates (2005), or the videos at: 
 “eclipsetutorial.sourceforge.net/index.html” 
 “courses.coreservlets.com/Course-Materials/java5.html” 
 
Repast Simphony 
Repast Simphony is an open-source agent-based modeling toolkit that was developed (and continues to be 
maintained) by Argonne National Laboratories. It includes point-and-click model development and 
execution environments that speed model development. 
 
Repast Simphony releases are hosted by SourceForge.net. To download a copy of Repast Simphony, go to 
“repast.sourceforge.net/download.html”.  Click on ‘here’ in the first paragraph to obtain installation 
instructions for your type of computer. Because the file size is large (about 400 MB), the download may 
take a long time. 
 
The Repast Simphony installer downloads a version of Eclipse. Even though the version of Eclipse that it 
downloads may be slightly older than the one you downloaded for use with igraph (in section B above) 
allow the installer to download this additional copy of Eclipse. Because of version incompatibilities, adding 
Repast Simphony to your existing Eclipse installation may not work. 
 
Because you will frequently refer to it, you should also download the Repast Simphony Javadoc API 
(application programming interface). This is documentation about the Simphony classes and methods, and is 
available at “repast.sourceforge.net/docs/docs_main.html”. To open the documentation, click on the html 
file ‘index’. You will find it useful to keep this file open while you are working with Repast Simphony. 
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D.  Java and Repast Simphony continued 
 
Repast Simphony continued 
To start using Repast Simphony, go to “repast.sourceforge.net/docs/docs_main.html” and download the 
PDF file containing the introductory tutorial and frequently asked questions (FAQ). Read the FAQ and 
work through the tutorial. Don’t omit this step. Learning Repast is a non-trivial exercise, and must be 
approached with discipline and diligence. Learning Repast with a friend or study group makes the process 
flow more easily. 
 
Go through the Repast tutorial, in the following order: 
1. Section 0: Introduction to Repast Simphony 
2. Section 2: Creating a Simple Repast Model 
3. Section 4: Creating an Animal Network Model 
4. Section 3: Creating a Predator-Prey Model 
 
Please note the following: 
 The tutorial is many pages, but they go by very quickly. It does not take much time to complete the 

tutorial. 
 Because the Getting Started Guide tutorial may be out of step with the most recent version of Repast 

Simphony, the tutorial’s screen shots and the results on your monitor may look different. In general, 
pay more attention to the screen shots for what should be entered as property values. The tutorial 
descriptions are often incomplete. 

 After you open Eclipse to start working with Repast Simphony the first time, you need to click on the 
‘Open Perspective’ icon in the upper right corner of the Eclipse workbench, and select ‘Other > 
Repast Simphony’. 

 As you work through the tutorial, be very careful with spelling, and follow the instructions exactly. 
 Documentation for Repast Simphony is sparse. Often, the only way to find out about system details is 

by trial and error. Or, you can consult the Repast Simphony email archives on the support network. It 
is a good idea to join the Repast Simphony user mailing list. To join the user mailing list, go to:   

https://lists.sourceforge.net/lists/listinfo/repast-interest.  
There you will also find the list archives. 

 When you set up a new Repast Simphony project, keep the default ‘model.score’ as the ‘Score File 
Name’. Don’t change this to another name. 

 As you start working with Repast Simphony, if you experience the GUI intermittently freezing, go to 
the Repast Email archive, and follow the instruction in the email from Eric Tatara dated 9/15/2009 
with subject ‘Freezing GUI at start-up’. 

 Make the following change to the file boot.properties in the folder 
“…/eclipse/plugins/repast.simphony.runtime/”: change the line “log4j.rootLogger = error” to 
“log4j.rootLogger = error, console”. This will allow certain error messages to be output to your 
Eclipse console, and simplify your learning curve. Changing this file may require you to change the 
security permissions for updating the file; if so, check with you computer administrator about how to 
do this. 
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D.  Java and Repast Simphony continued 
 
Repast Simphony continued 
Following are additional comments that may help you through the Getting Started Guide tutorial: 
 Page 29 (Starting the Repast IDE): When you install Repast, it will place a round blue icon with the labeled 

“Repast Simphony IDE” in your start menu (in the Windows version). Click the icon to start Simphony. 
 Page 31: The first tutorial sets up a model of seven gas gauges that measure the pressure at various points in a 

directed network of gas pipelines. 
 Page 36: On this page, Simphony provides four noteworthy defaults: the Score File Name is ‘model.score’, the 

Package name is ‘infrastructuredemo’, and the Model Name is ‘InfrastructureDemo’. Carefully note these names 
and exactly how they are spelled. Also, on the page is a check box that enables Groovy and the Visual Editor, 
allowing you to enter model parameters using a simplified method (in the Getting Started tutorial, this check box 
is absent). 

 Page 38: The “top level context” is the Model Name ‘InfrastructureDemo’ at the top of the middle Eclipse 
window. 

 Page 41:  The projection for the GasNode agent will be a network. 
 Page 44:  When you change the Dimensionality property to 2, the Label will change to ‘Grid2D’. Change it back 

to ‘Grid’. 
 Page 45:  The Width and Height elements are found by expanding the Grid projection element in the 

model.score. To expand an element, click on the arrow next to the name. 
 Page 48:  Be very careful. The ‘infrastructuredemo’ package is located under ‘src’ in the left-hand Package 

Explorer pane of Eclipse. Right click on it. 
 Page 50:  The agent name should be ‘GasNode.agent’. 
 Page 51:  You may enjoy taking a look at the GasNode.groovy code. Do this by double-left-clicking on 

GasNode.groovy under the package ‘infrastructuredemo’. 
 Page 56:  In the latest version of Repast Simphony, substep 4d from the tutorial is missing. Therefore, for Step 4, 

enter values according to the substep descriptions, not according to the substep numbers (eg, “pressure” should 
be entered in substep 4d, not in substep 4e). 

 Page 57:  ‘Step 6:Optionally Select a Return Type for the Behavior’ should be set to blank. 
 Page 61:  Steps 3 and 4 of the Change Pressure task may be left as their defaults. 
 Page 69:  The button to click in order to apply the changes is the ‘Save Model’ button. 
 Page 74:  Don’t try to run the model yet. First, you need to change the pressure property of one of the agents. 

Otherwise, the model Tick Count will go to ‘-1’, and you will have to reset the model and reenter agents on the 
grid. To learn how to change the pressure property, go to the next page. 

 Page 78:  Choose ‘XML File’ instead of ‘Delimited File’. The Delimited File option will not work. 
 Page 79:  Browse to the ‘freezedried_data’ directory of the Infrastructure_Demo project. 
 Page 81:  Select the source type ‘XML File’, instead of ‘Delimited File’. 
 Page 82:  Browse to the freezedried file, instead of to the freezedried directory. 
 Page 83:  Instead of the ‘Edit Style Button’, click on the pen and paper icon above the green cross. 
 Page 101:  Change the Series Name to ‘toString’. 
 Page 111: Set ‘Step 3f: Optionally Choose Whether or Not to Shuffle Ties in the Scheduling Order for the 

Behavior’ to False. 
 Page 112: ‘Assign a Uniform Random Number Between 5.0 and 15.0’ is in the Statistics group. 
 Page 159:  Skip the sections 3-02-1 to 3-02-5 (unless you are interested in the Visual Agent Editor) and go to 

section 3-98. The tutorial doesn’t show you how to implement what is done in sections 3-02-1 to 3-02-5. 
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D.  Java and Repast Simphony continued 
 
Repast Simphony continued 
There are two Repast Simphony models, in two Eclipse packages, that are used in Chapter six of the report. 
These packages are found as zipped files on the SOA web page for this report. You can download the files 
by clicking on: 
 Schelling segregation model 
 Sugarscape model 
 
To use one of these models, download its zip file, unzip it, and save the unzipped (extracted) contents to a 
temporary place on your hard drive (such as “D:/temp”). The name of the zipped file for the Schelling 
segregation model is “research-complexity-model-schelling-v1a.zip”, and the name of the zipped file for the 
Sugarscape model is “research-complexity-model-sugarscape-v1a.zip”. 
 
Unzipped, each file contains a folder that is an Eclipse package. The package for the Schelling segregation 
model is named “Schelling”, and the package for the Sugarscape model is named “Sugarscape”. Use Eclipse’s 
‘File > Import > General > Existing Projects into Workspace’ function to import the two packages. For 
example, to import the Schelling segregation model, browse to the folder  (‘root directory’) ‘Schelling’ and 
import the package Schelling (including all the files it contains) to your Eclipse workspace (be sure to check 
the box labeled ‘Copy projects into workspace’). Once it is imported, you will see a new package called 
‘Schelling’ in the Eclipse Package Explorer window. 
 
Under the folder ‘Schelling’ you will find the model’s three Java program files in the folder “Schelling > src 
> schelling”. Double-click a file to see its contents. The ‘model.score’ for Schelling is located in the folder 
“Schelling > schelling.rs”. Double-click on it to see the model’s score. 
 
To run the Schelling model, click on the black down arrow of the Eclipse ‘run’ icon: 
Then click on ‘Run Schelling Model’. (If you don’t see such an item to select, click on ‘Organize 
Favorites…’. Then click on ‘Add’ and add ‘Run Schelling Model’ to the list of options.) 
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